Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

In regards to the COVID-19 situation

Your support team is currently doing their best to offer the best support possible despite the current COVID-19 situation. However during these exceptional circumstances, please note that you should expect a response time of 2-3 business days, until further notice.Rest assured that we will still do our best to handle your requests as soon as possible! Everyone stay safe and healthy! 😷

BP Profile Search doesn’t work since last Grimlock update

This topic is resolved
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    Hi ThemoSaurus Support Team,

    This morning, I connect to my new test site and see that some plugins have updates to install: Grimmlock, Grimlock for BuddyPress and Kiriki (if I remember well).
    I do updates, no problem during updates.

    I go to the front-end part of my site and do a quick member search.
    And there… all members are displayed. Last thursday, all was fine. But now, whatever the research, all the members are displayed.

    I deactivated all my custom code snippets and all plugins (except BuddyPress, Grimlock, Grimlock for BuddyPress, Kiriki and BP Search Profile) but the result is the same: all members are displayed.

    Could you help me with this? I was supposed to present my work to my customer this week, and now the main feature is broken, it starts to worry me. I would like not to disappoint my client…

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts
    This reply has been marked as private.
    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    Hi @gillesderon,

    I’m very sorry to read about your issue… Especially so close to a deadline.
    Do you have any caching system set up? For instance like WP Rocket or something from your hosting service?

    Thank you.

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    If that the case, could please deactivate all plugins and snippets as you’ve suggested and then empty your caching system if existent?

    Thank you.

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    Hello @themosaurusrex,

    No, I do not use any caching plugin.

    I just did the Grimlock today udpate.
    I deactivated all plugins (except BP Profile Search, BuddyPress, Grimlock, Grimlock for BuddyPress and Kirki) and all snippets.
    I cleared my browser’s cache.

    Same issue…

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    Thank you.
    And the odd thing is that the default search is still functioning correctly…

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts
    This reply has been marked as private.
    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    I just tried without Grimlock, Grimlock for BuddyPress and Kirki activated… Leaving only Gwangi, BuddyPress and BP Profile Search. And the profile search still does not work. ?

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    Yes, and all was working fine last week…
    The only change was the plugins update.

    I’m going slightly mad..

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    Hello @themosaurusrex,

    I just tried something interesting: I switch the theme from Gwangi child to Gwangi, and there the search is working.

    So I took a look into my Gwangi child theme directory and found the functions.php modified by MeshPros. Maybe this file is the source of my troubles.
    But if I put back the original functions.php and if I put back the Gwangi child theme, the search is not working anymore and send me to a ‘Coming Soon’ page.

    I understand less and less…

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    The Members Sidebar Right search is not working, sending me to ‘Coming Soon’ page.

    But if you go to /membres/, the search is working.

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    So, there is clearly something wrong with code made by MeshPros. Is there any chance you could use Gwangi for your deadline and then look for the resolution after your presentation, once the pressure is off?

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    The MeshPros code has to be reviewed, for sure.
    But I don’t understand why without the MeshPros code, the Members Sidebar Right search is still not working. And the Members Sidebar Left page displays a ‘Coming Soon’ page.

    Should i uninstall and then reinstall the Gwangi child theme?

    Gilles Deron
    Participant
    • 31 Topics
    • 98 Posts

    OK, I deleted the Gwangi child theme and upload it again. Now the search is working.

    Thanks for your time.

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    Hi @gillesderon,

    I’m glad to read that you’ve found the solution to this issue. I would have really liked to be able to help you more.

    I hope your demo will run smoothly. I wish you the best of luck with your meeting!

    Cheers,

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘BP Profile Search doesn’t work since last Grimlock update’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️