Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

Due to the decrease in our staff due to vacations, our response time may be longer.

Be sure we're doing our best to manage your topic as soon as possible.

Can’t activate newly registered accounts – endless loop / redirect

Find Answers and Get Support Forums Cera – Intranet & Community Theme Website Setup Pages Can’t activate newly registered accounts – endless loop / redirect

This topic is resolved
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Angela
    Participant
    • 6 Topics
    • 24 Posts
    @angelalgibson

    Hello, I installed Cera over the weekend. I tried creating an account today through the registration page. That went fine and I received an email to activate account. I clicked on the link and it goes through loop/redirect with nowhere to activate. There is nowhere to enter activation code manually either. Followed info here: https://doc.themosaurus.com/creating-activation-registration-pages/

    Here is a link to short video showing behaviour: https://www.dropbox.com/s/urho521t6mukhe0/cera-activation-loop.mp4?dl=0

    I have tried re-sending the link to no avail. Same problem.

    I have disabled WP Hide Login (changed login URL to /365Connect instead of generic wp-login.php). I put everything back to wp-login.php for testing, but still doesn’t work.

    I have disabled My Private Site plugin and it still does the same thing. So there is something wrong with the setup of the demo content that I imported.

    Please help.

    Thank you.

    ~ Angela

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hi Angela,

    This issue can occur if you activate your account multiple time with the same key, for instance by open the link provided in the automatic BuddyPress email in your browser and then, by manually entering the key in the activation form. This can be also happen when you try to use different sessions (administrator and test subscriber) with the same browser and follow the activation link several times in a row.

    To help you to solve this issue, you might also be interested by the following BuddyPress support forum topics:

    New User Registration Problem: Invalid Activation Key

    [Resolved] Need activation key???

    Unfortunately, this issue is related with BuddyPress plugin and our theme has nothing to do with that. We remind you that a theme affects the presentation and visual style of your site, while plugins add all kinds of features and functionalities.

    We suggest you to ask for more help on the BuddyPress support forums: buddypress.org/support.

    Don’t hesitate to share the solution with us. I’m sure it will help other users facing the same issue. By doing this, you’ll make a great contribution to this forum, and we thank you very much for that! #SharingIsCaring 💪🏻

    Regards,

    Angela
    Participant
    • 6 Topics
    • 24 Posts
    @angelalgibson

    “This issue can occur if you activate your account multiple time with the same key” — I can never activate even once. I can never get to the activation page to enter activation key, nor can I take advantage of clicking on the activate button with a pre-filled activation key UNLESS the site is not private.

    “Unfortunately, this issue is related with BuddyPress plugin and our theme has nothing to do with that.”

    I know your stock answer is there is nothing wrong with your theme, but you should know that I have now tried using My Private Site (which you recommend, so proper testing with Buddypress, your theme, and that plugin should be a given), and I have also tried with Force Login plugin, All-in-One-Intranet plugin, and PPWP – WordPress Password Protect Page Plugin. Each of these exhibited the same behavior with your theme.

    So at the moment when using your theme, I have the choice of not having a private site to get the registration/activation process to work correctly — which entirely defeats having a private intranet OR I have one of the “hide your site behind login” plugins active, but have to forgo self-registration and manually approve people who register. Also, not tenable. OR I can use a plugin to skip activation and automatically approve site registrants, which is a security/spam issue.

    Interestingly, WOffice theme registration and activation process works seamlessly without the need for a third-party plugin to hide the site behind login — unfortunately I like the “look” of your theme better. But that does me no good for the site to be aesthetically pleasing if it’s not private and functional.

    Angela
    Participant
    • 6 Topics
    • 24 Posts
    @angelalgibson

    In case anyone else runs into this issue (I know I’m not the only one) I was finally able to get everything working using the Force Login plugin and adding the following code the function.php file in the child theme:

    /**
    * Bypass Force Login to allow for exceptions.
    *
    * @param bool $bypass Whether to disable Force Login. Default false.
    * @param bool $url The visited URL.
    * @return bool
    */
    function my_forcelogin_bypass( $bypass, $url ) {
    $url_path = parse_url( $url, PHP_URL_PATH );

    // Allow these absolute URLs
    $allowed = array(
    home_url( ‘/register/’ )
    );
    // Allow the registration URLs
    if ( wp_registration_url() == $url ) {
    $bypass = true;
    } elseif ( ‘activate’ === substr( $url_path, 1, 8 ) ) {
    $bypass = true;
    }

    return $bypass;
    }
    add_filter( ‘v_forcelogin_bypass’, ‘my_forcelogin_bypass’, 10, 2 );

    That allows me to have the site private for use as intranet, still have the Cera login and registration pages, and I am now able to click on the activation link in the emails and successfully load the activation page to click on the activate button below the auto-populated activation code.

    Angela
    Participant
    • 6 Topics
    • 24 Posts
    @angelalgibson
    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hello Angela,

    Thank you for your honest feedback. I completely understand your frustration.

    As you said, my Private Website is a plugin we recommended to you because it is compatible with our theme. But what does that mean? It means that we make sure that the theme style is correctly applied to the My Private Website features. Our theme is compatible with a lot of plugins and we do our best to make sure that all these plugins remain compatible with our theme, update after update.

    I think your problem might be related to an incompatibility issue between BuddyPress plugin and My Private Website. The fact that no one has reported this issue before makes me think that it may have been caused by the last update of one of these plugins. However, we cannot ensure that all compatible plugins, in your case, My Private Website, remain compatible with other plugins. This is the job of plugin authors, not theme authors. Also, I’m afraid we can’t help you solve a problem with a plugin we didn’t develop.

    To make sure that the theme is not related to this issue, I suggest that you temporarily change the theme. For example, activate Twenty-Twenty Two. This theme is so basic that if this issue still occurs, it means that it comes from third-party plugins. In this case, I recommend you to report it to the authors of My Private Website. They will be better able to help you with their plugin. If this issue comes from their side, they will be able to solve it in the next update.

    If this issue is solved when you change your theme, it means that something in our framework is interfering. In this case, come back to us and be sure we’ll investigate further.

    Anyway, we thank you for sharing this quick fix with us. I’m sure it will help other users facing the same issue. By doing this, you’re making a great contribution to this forum, and we thank you very much! #SharingIsCaring 💪🏻

    We hope you understand. If you have any other questions or requests related to the use of our theme, please feel free to create other forum topics.

    Best,

Roboraptor 🦖
Themosaurus Topic Closer

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Can’t activate newly registered accounts – endless loop / redirect’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️

Discover MatchPress

Skip • Like • Super-Like

Add powerful matching features like Member likes, skips, super likes, conditional private messaging and much more.

Setup Your Cera or Gwangi powered Community Website and Turn it into an iOS and Android App

15% discount for Cera users

To unleash the full power of your Cera or Gwangi theme, we have partnered with the Zipline team. Your community website can now be fully setup and turned into your very own custom app for iOS and Android.

Whether you've newly acquired the theme or already got your site up and running, Zipline got you covered. And we got you an incredible discount.

Holiday, Weather & Festive effects
to pimp your WordPress Site