Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

Due to the decrease in our staff due to vacations, our response time may be longer.

Be sure we're doing our best to manage your topic as soon as possible.

Can’t See Video In Posts

This topic is resolved
Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth

    So far everything is working great. But, I tried to add a YouTube video in a post, but when I publish it the video isn’t there (even though it shows in the WP Admin Dashboard when I’m creating the post).

    I have the Post Format set to “Video”. The block I am using is “YouTube”. In the YouTube -> Advanced -> Additional CSS Class(es) section there is this “wp-embed-aspect-16-9 wp-has-aspect-ratio”. If I remove the custom CSS then the video shows in the post but it doesn’t display correctly – it is very thin/squished.

    Please see all screenshot attachments.

    Our site depends heavily on YouTube videos, so this is a major issue for us.

    Any help is greatly appreciated!

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hi Jsmooth,

    Thank you for reporting this to our attention.

    My best guess is that your issue might probably be caused by some conflicting third party plugin or some extra code snippet as we don’t encounter this issue with our demos. I tried a new installation with everything up to date, by all is working fine on our side. Please find the attached screenshot.

    Could you deactivate all plugins that have not been installed with your theme during its setup and all existing custom PHP code snippets please? And then, could you confirm me that the issue is still persisting please?

    Please also make sure that you have the latest theme version and that all recommended plugins are up-to-date. Finally, you could also consider clearing all activated caching system as well as your browser cache before investigating any further. If you want to read more on what browser cache is and how to clear it, here is an article that might help you: How to Clear Internet Cache in Every Major Browser.

    Thank you.

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth

    I cleared the cache, but nothing changed. I went through all plugins and made them inactive, and the video showed up. I installed only the basic plugins and it went away again. The 5 plugins that are installed are Envato Market, Grimlock, Grimlock Animate, Grimlock Login and Kirki Customizer Framework. I went through each one-by-one and the one causing it to not show is Grimlock.

    I’m going to do a fresh install and see if that helps – otherwise I might have to go with a different theme. That’s unfortunate, because this is the the theme that checks all of the boxes for what I need.

    JSmooth

    Roboraptor
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 342 Posts
    @roboraptor

    Hi there,

    Thanks for getting in touch!

    We provide support only during Belgian business hours (Monday to Friday, from 8:30 am – 5:30 pm CEST), and our current response time can be up to 1 business day. We’ve received your request and we’ll get you an answer ASAP.

    We really thank you for your patience!

    In the meantime, feel free to check out our documentation resources for more help: https://doc.themosaurus.com/

    Kind regards,

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hi Jsmooth,

    Thank you for your feedback

    That’s very odd. 🤔 It’s best if we take a quick look at this. Could you create a new website user for us please? If possible with administrator capabilities so we can make a quick check of your settings.
    You can post the user name and password in your next reply and mark it as private to keep this between us.

    Also, are we free to deactivate plugins for our tests? In this case, I invite you to make a backup before we investigate your website further in order to make sure you don’t loose any data if something goes wrong.

    Thank you.

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    Roboraptor
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 342 Posts
    @roboraptor

    Hi there,

    Thanks for getting in touch!

    We provide support only during Belgian business hours (Monday to Friday, from 8:30 am – 5:30 pm CEST), and our current response time can be up to 1 business day. We’ve received your request and we’ll get you an answer ASAP.

    We really thank you for your patience!

    In the meantime, feel free to check out our documentation resources for more help: https://doc.themosaurus.com/

    Kind regards,

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    Roboraptor
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 342 Posts
    @roboraptor

    Hi there,

    Thanks for getting in touch!

    We provide support only during Belgian business hours (Monday to Friday, from 8:30 am – 5:30 pm CEST), and our current response time can be up to 1 business day. We’ve received your request and we’ll get you an answer ASAP.

    We really thank you for your patience!

    In the meantime, feel free to check out our documentation resources for more help: https://doc.themosaurus.com/

    Kind regards,

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hi Smooth.

    Thank you, but it seems the WordPress credencials don’t work. I could login in to the staging website, but not in WordPress Dashboard. Can you please check them?

    Thank you in advance.

    Best,

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hi Jsmooth,

    Thank you, we could login successfully.

    To help us getting clues and find a solution to this issue, please activate logging on your website, just turn WP_DEBUG to true, by pasting the following code lines in your wp-config.php file, just before the line that says ‘That’s all, stop editing! Happy blogging.’:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings 
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    More on this in the following topic: Debugging in WordPress.

    Thank you.

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Hi Jsmooth,

    Thank you. 🙂

    As predicted, we’ve met an error again when adding a video. However this time, thanks to the code snippet that you’ve recently added to your wp-config.php file, we should be able to read the error.

    Could you share the content of your debug.log file with us please? You can post the content of this file as plain text in your next reply and mark it as private to keep this between us.

    After having reviewed your next reply, we’ll be able to tell you if the issue is caused by our product, a third party plugin or any type misconfiguration on your server.

    If we’re not able to help, we’ll recommend you to transfer the error logs to the plugin author or to your server hosting support.

    Thank you.

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth
    This reply has been marked as private.
    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth

    I tried adding audio in a post and it shows in the backend (WP Admin) but it doesn’t show in the post.

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Thank you for your feedback Jsmooth. Please allow us some time to investigate. We’ll be back to you as son as we found from where this issue might come from. 🙂

    Best,

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Can you please add the following code snippet to your website:

    /**
    * FIX: Display Correctly Videos in Posts
    */
    body.single.single-post #main > [id^="post-"], body.single.grimlock--single #main > [id^="post-"] {
        flex-wrap: nowrap !important;
        flex-direction: column !important;
    }

    To add this code snippet to your site, we recommend that you paste it to the Custom CSS panel of your WordPress Customizer. Just go to your dashboard and navigate to “Appearance > Customize > Additional CSS”.
    Pasting your code snippet there should do the trick for you.

    Also, it’s important to remember that we share snippet only to solve issues with our theme. Any further request for CSS snippets will have to be part of a defect that needs to be fixed urgently. No snippets will be shared otherwise.

    If you want to go further with the customization of your website, we advise that you require customization work.

    Regards,

    jsmooth
    Participant
    • 3 Topics
    • 14 Posts
    @jsmooth

    I thought I posted my response here yesterday. Well, your code worked! I really appreciate the support!

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 6205 Posts
    @themodactyl

    Glad to read that this snippet helped you solve this Jsmooth! 🙂

    If you’re happy with our theme, feel free to review our theme on our Themeforest page dedicated to Gorgo: Multi-Purpose Collaborative Blog & Community BuddyPress Theme.

    It’s very appreciated and it helps us making our products more known to new potential customers, which allow us more time to improve the quality over time and develop new features. It’s a win-win !

    And by doing this, you will be making a great contribution to our community! #SharingIsCaring ❤️

    Thank you!

Roboraptor 🦖
Themosaurus Topic Closer

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Can’t See Video In Posts’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️

Discover MatchPress

Skip • Like • Super-Like

Add powerful matching features like Member likes, skips, super likes, conditional private messaging and much more.

Setup Your Cera or Gwangi powered Community Website and Turn it into an iOS and Android App

15% discount for Cera users

To unleash the full power of your Cera or Gwangi theme, we have partnered with the Zipline team. Your community website can now be fully setup and turned into your very own custom app for iOS and Android.

Whether you've newly acquired the theme or already got your site up and running, Zipline got you covered. And we got you an incredible discount.

Holiday, Weather & Festive effects
to pimp your WordPress Site