Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

Due to the decrease in our staff due to vacations, our response time may be longer.

Be sure we're doing our best to manage your topic as soon as possible.

Dropdown menu stopped working

This topic is resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Jani
    Participant
    • 1 Topics
    • 5 Posts
    @roseboxco

    Hello,

    The dropdown menu in my ‘primary menu’ suddenly stopped working (sometimes).
    It still works while logged in as admin, but doesn’t work while logged out. It also stops working when I click and visit one of the pages in the dropdown menu…
    On mobile, when I try to open the menu, it opens for 1sec and automatically closes again.

    The dropdown menu in my ‘secondary menu’ just doesn’t work at all (it’s only visible to logged in users).

    I’ve provided some screenshots and hope this accurately describes the issue I’m having.

    Thanks in advance.

    Roboraptor
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 136 Posts
    @roboraptor

    Hi there,

    Thanks for getting in touch!

    We provide support only during Belgian business hours (Monday to Friday, from 8:30 am – 5:30 pm CEST), and our current response time can be up to 1 business day. We’ve received your request and we’ll get you an answer ASAP.

    We really thank you for your patience!

    In the meantime, feel free to check out our documentation resources for more help:

    FAQ & Support Documentation

    Kind regards,

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4836 Posts
    @themodactyl

    Hi Jani,

    Thank you for buying our theme. We hope it will meet all your expectations! 🙂

    My best guess is that your issue might probably be caused by some conflicting third party plugin or some extra code snippet as we don’t encounter this issue with our demos.

    Could you deactivate all plugins that have not been installed with your theme during its setup and all existing custom PHP code snippets please? And then, could you confirm me that the issue is still persisting please?

    Please also make sure that you have the latest theme version and that all recommended plugins are up-to-date. Finally, you could also consider clearing all activated caching system as well as your browser cache before investigating any further. If you want to read more on what browser cache is and how to clear it, here is an article that might help you: How to Clear Internet Cache in Every Major Browser.

    We’re waiting for your feedback.

    Thank you.

    Jani
    Participant
    • 1 Topics
    • 5 Posts
    @roseboxco

    Hi Manathan,

    I’ve managed to get the main menu dropdown working again (was an issue with a plugin and the plugin author provided me with some CSS code to get it functioning).

    My secondary menu however, is not dropping down and the issue does not seem plugin-related.
    (This menu is only visible to logged in users, but I’ve disabled the membership plugin so it’s visible to everyone now)

    Thank you for your reply.

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4836 Posts
    @themodactyl

    Hi Jani,

    I’m glad to read you’ve been able to solve this!

    It’s best if we take a quick look at this. Could you create a new website user for us please? If possible with administrator capabilities so we can make a quick check of your settings. You can post the user name and password in your next reply and mark it as private to keep this between us.

    Also, are we free to deactivate plugins for our tests? In this case, I invite you to make a backup before we investigate your website further in order to make sure you don’t loose any data if something goes wrong.

    Thank you.

    Jani
    Participant
    • 1 Topics
    • 5 Posts
    @roseboxco
    This reply has been marked as private.
    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4836 Posts
    @themodactyl

    Hi Jani,

    Thank you for granting us access to your WP Admin. We found from where this issue is coming from.

    Be aware that, as you can see in the secondary menu zone, there is a clip-path that create an inclined shape. In fact, clip-path act like a overflow:hidden;. For this reason, all elements that that go beyond this zone are hidden. As this zone was not build to host a submenu, the only solution is to disable the clip-path by using the following code snippet:

    /**
    * Disable Clip Path on Secondary Menu
    */
    .main-navigation .navbar-nav--secondary{
    	clip-path:none;
    }
    .main-navigation .navbar-nav--secondary > li > .sub-menu {
        left: auto;
        right: 0px;
    }

    To add this code snippet to your site, we recommend that you paste it to the Custom CSS panel of your WordPress Customizer. Just go to your dashboard and navigate to “Appearance > Customize > Additional CSS”.
    Pasting your code snippet there should do the trick for you.

    Also, it’s important to remember that we share snippet only to solve issues with our theme. Any further request for CSS snippets will have to be part of a defect that needs to be fixed urgently. No snippets will be shared otherwise.

    If you want to go further with the customization of your website, we advise that you require customization work.

    Regards,

    PS: Hello belgian friend! 🇧🇪

    Jani
    Participant
    • 1 Topics
    • 5 Posts
    @roseboxco

    Hi Manathan,

    This works perfectly, thank you so much.

    I’ve encountered a different problem now, my mobile menu doesn’t scroll anymore.
    I’ve restored the backup, removed the code snippet, tried some other css to fix the scrolling (this adds a scrollbar to the menu on PC also, so it’s no solution) but still doesn’t scroll. I’m not sure what has changed from before… Very strange.

    Anyway, thank you for providing me with the CSS snippet ^ – I’ll try some more and hopefully get my new problem sorted .

    Greetings,
    Jani

    ps: Hello to you too ,fellow belgian!

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4836 Posts
    @themodactyl

    Thank you for your feedback Jani.

    I took a look but I can’t reproduce this issue. Could you provide us with screenshots of your website please? Please don’t hesitate to comment or highlight your screenshots to help us better understand your issue.

    By the way, I noticed the sub-menu in the secondary nav is not always set correctly. I just updated the snippet in my previous answer to make it fit on large screens.

    Thank you.

    Jani
    Participant
    • 1 Topics
    • 5 Posts
    @roseboxco

    Here’s a wetransfer link with 2 screen recordings of the issue I’m facing : Mobile Screen Recordings

    In the first screenrecording, you can see the mobile menu not scrolling down (only part of the menu is accessible/visible).
    I’ve found a ‘solution’ online, the css code below, but this creates scrollbars on the desktop menu.

    .main-navigation {
    overflow: scroll !important;
    max-height: 84vh;

    In the second screenrecording, you can see the mobile menu working perfectly with the css code above ^ , but this creates the scrollbar on the desktop version (as you can see in the screenshot I’ve attached).

    This used to work perfectly fine, it also works perfectly fine (on mobile) on the sinclair demo – so I’m not sure what happened.
    I’ve just noticed that, when I disable the main ‘grimlock’ plugin, the menu starts working again – but obviously I can’t disable this plugin.

    As you’ve already noticed, I’m no expert in coding 🙂 so I’m sorry for the trouble.

    Have a great weekend, and thank you again!

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4836 Posts
    @themodactyl

    Hi Jani,

    Thank you for your detailed feedback. We will investigate further to find out how we can solve this.

    We will be back to you ASAP.

    Thank you for your patience.

    Regards,

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4836 Posts
    @themodactyl

    We found the solution, simply add the following code snippet to your website:

    /**
    * Fix scroll on mobile
    */
    body.ov-h{
    	overflow:auto !important;
    }

    To add this code snippet to your site, we recommend that you paste it to the Custom CSS panel of your WordPress Customizer. 🙂

    Regards,

Roboraptor 🦖
Themosaurus Topic Closer

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Dropdown menu stopped working’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️

Discover MatchPress

Skip • Like • Super-Like

Add powerful matching features like Member likes, skips, super likes, conditional private messaging and much more.