Feeling foolish as login just never seems to work with Ajax

Home Forums Gwangi – Dating & Matchmaking Community Theme Compatible Plugins Login With Ajax Feeling foolish as login just never seems to work with Ajax

This topic contains 5 replies, has 2 voices, and was last updated by  Themosaurus 5 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4328

    Ivan
    Participant
    • 20 Posts
    @picturebox1

    Hi Themosaurus,

    I have really been really struggling, over several days, to set up the login links for the https://loversbee.com website. The register link works and the login on the registration page also works. But the links from the menu don’t and just link back to the home page. I have tried every possible combination and even created another buddypress website and that worked fine with the buddypress shortcode.

    I have read and re-read your website/ajax support/buddypress support to try and fix this login problem. I really don’t know what I am missing.

    Please help!

    Seasons Greetings,
    Ivan

    #4335

    Ivan
    Participant
    • 20 Posts
    @picturebox1
    This reply has been marked as private.
    #4340

    Themosaurus
    Keymaster
    • 1673 Posts
    @themosaurus

    Hi @picturebox1,

    Unfortunately, we’re not able to login into your website to review your settings as we’re not finding your login page. Could please share its URL with us?

    Thank you.

    #4343

    Ivan
    Participant
    • 20 Posts
    @picturebox1

    Hi themosaurus,

    Thank you for getting back so quickly.

    The direct link is https://loversbee.com/register/#pills-login
    This is the only one that works client side and is accessed from the register page.

    Best wishes,
    Ivan

    #4344

    Ivan
    Participant
    • 20 Posts
    @picturebox1

    P.S. Obviously I could just use the /register/#pills-login on the nav links. But I am not sure if I should do that.

    #4355

    Themosaurus
    Keymaster
    • 1673 Posts
    @themosaurus

    Hi @picturebox1,

    As a worst case scenario, you could simply add the /register/#pills-login to one of your navigation link and it should work.

    However, the best way seems to create a separated login page with Login With Ajax. This way, users clicking the register link will be able to login after having followed the “Login” tab and user clicking directly on the “Login” navigation menu will be presented with another Login With Ajax form.

    To do so, please carefully follow the steps described in our tutorial to setup your custom login page:

    Creating the Login Page

    If you have already done so and are still struggling, because you have created a new homepage page for your login page, you can either:
    – change the page template back to “Default Template” or “Full Width Template: Narrower” (recommended);
    – or make sure to create an extra Grimlock Section and paste the following shortcode in its text box:
    [login-with-ajax template="divs-only"] to display your login form.

    This should solve your issue. 😀

    Please enjoy the New Year’s Eve! We wish a happy New Year!

    Regards,

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Feeling foolish as login just never seems to work with Ajax’ is closed to new replies.