Hide Menu on Hero Page

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  Olivier 1 month, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #11978

    ec
    Participant
    • 4 Posts
    @ecpdx

    Greetings,

    Matching styles on mobile menu and Hero page is rather cumbersome. How can I hide the primary menu (navigation) just on the Hero page?

    Thanks.

    #11982

    Olivier
    Moderator
    • 1758 Posts
    @themosaurusrex
    Themosaurus Support

    Hi @ecpdx,

    Thank you for reaching out to us! 🙂

    We’re sure to understand what you’re referring to.

    Could you provide us with screenshots of your website please? Please don’t hesitate to comment or highlight your screenshots to help us better understand your issue.

    Thank you.

    #11985

    ec
    Participant
    • 4 Posts
    @ecpdx
    This reply has been marked as private.
    #12005

    Olivier
    Moderator
    • 1758 Posts
    @themosaurusrex
    Themosaurus Support

    Hi @ecpdx,

    I’m very sorry but this screenshot doesn’t show much and your issue is still very unclear…

    Please note that the mobile menu for our theme will cover up the content. (Please see attached.)

    Adding a transparent background to it will make it difficult to read the items displayed.

    Could you provide us with other screenshots of your website please? Maybe with more details ?

    Thank you.

    #12022

    ec
    Participant
    • 4 Posts
    @ecpdx

    Hi Olivier, is it possible to disable the menu completely on the Hero page?

    #12057

    Olivier
    Moderator
    • 1758 Posts
    @themosaurusrex
    Themosaurus Support

    Hi @ecpdx,

    To hide the menu on your Homepage, simply add the following code snippet to your website:

    /**
      * Hide the primary navigation menu items on Homepage.
      */
    .home .navbar-collapse {
        display: none !important;
    }

    To add this code snippet to your site, we recommend that you paste it to the Custom CSS panel of your WordPress Customizer. Just go to your dashboard and navigate to “Appearance > Customize > Additional CSS”.
    Pasting your code snippet there should do the trick for you.

    Also, it’s important to remember that we share snippet only to solve issues with our theme. Any further request for CSS snippets will have to be part of a defect that needs to be fixed urgently. No snippets will be shared otherwise.

    If you want to go further with the customization of your website, we advise that you require customization work.

    Regards,

    #12312

    Eliezer
    Participant
    • 1 Posts
    @eliezerzamora

    Hi,
    I would like to keep the side menu hidden for all users arriving at the page, leaving it up to them to show the panel with a click. As of now, it isn’t collapsed.

    Do you know how I can make this change?

    #12406

    Olivier
    Moderator
    • 1758 Posts
    @themosaurusrex
    Themosaurus Support

    Hi @eliezerzamora,

    Thank you for your great feedback. This cannot be achieve with our theme (yet). As multiple users have reached out to request more options and more control with the vertical navigation, we’ve added some improvements to our task list.

    Sadly, no release date can be disclosed yet. You can rest assured that we will work on fine tuning this in the coming updates. 🙂

    Please note that I took the liberty to move this topic to our Feature Requests forum. As your idea could be a nice addition to our theme, we will implement this feature if other community members upvote your request.

    We’ll keep you informed. Thank you very much for contributing to this theme!

    Best regards,

    #14549

    Olivier
    Moderator
    • 1758 Posts
    @themosaurusrex
    Themosaurus Support

    Hi guys,

    We recently released a new version of Cera (v 1.1.2) to provide extra options to better control the visibility and behavior of its vertical navbar. Updating your theme, Grimlock plugins and all the other recommended plugins to the latest version should fix this issue.

    If you have correctly updated the theme and Grimlock, the problem should now be fixed. You might still be seeing the issue because your browser cache is showing you an older version of the page (browsers do that to load pages faster). So to see that the issue is resolved you will need to empty your browser cache and reload the page. If you want to read more on what browser cache is and how to clear it, here is an article that might help you:
    https://www.lifewire.com/how-to-clear-cache-2617980

    To update your theme, you can download and install the Envato Market plugin (https://envato.com/market-plugin/) on your WordPress site.

    Once the plugin is installed and activated, go to “Envato Market” in your admin menu and follow the instructions under “Activate Envato API Connection”.

    When this is done, you will see your purchased themes under the “Themes” tab and you should be able to update your theme from there by clicking the “Update available” button.

    Cheers,

    #14553

    Olivier
    Moderator
    • 1758 Posts
    @themosaurusrex
    Themosaurus Support

    We’re glad that we have been able to fulfill your request!

    If you are happy with your theme so far, feel free to review our theme on ThemeForest. Each review is greatly appreciated as it helps us grow on the platform and allows us to improve the quality of our products, bring new features and make even more awesome themes! To do so, it is very simple: go to your ThemeForest downloads page (https://themeforest.net/downloads), find your theme and click on the stars.

    Thank you! 🙏

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.