Home page search form

This topic contains 10 replies, has 2 voices, and was last updated by  Jason 5 days, 2 hours ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #8336

    Pierre Laroche
    Participant
    • 6 Posts
    @pragmacafe

    Everything work fine, but in the search form, when i choose an option from a scroll bar i have a blank line right after the “——–“.
    So the first item is a plain line, then a blank line, then all items are list.

    Any way to get rid of that blank line?
    Thank you!

    #8337

    Jason
    Participant
    • 183 Posts
    @themoceratops

    Hi @pragmacafe,

    Thank you for your precious feedback. There is definitely an issue in our theme which will be fixed in the next update.

    In the meantime, here is a CSS snippet that should resolve the issue while we work on the update :

    .bps_form .editfield .bps-custom-select select option:not([value*=" "]) {
        display: none;
    }

    You can paste this CSS snippet by going in Appearance > Customize > Additional CSS from your admin dashboard.

    Best,

    #8339

    Pierre Laroche
    Participant
    • 6 Posts
    @pragmacafe

    Thank you for the quick response, however, now the list doesn’t show anything or only somme line. Like the from…to i get nothing in the list, the city (ville) down down list i have maybe 10 items only.
    regards

    #8340

    Jason
    Participant
    • 183 Posts
    @themoceratops

    Hi @pragmacafe,

    Could you please create a new website user for us? If possible with administrator capabilities so we can make a quick check of your settings.
    You can post the user name and password in your next reply and mark it as private to keep this between us.

    Cheers,

    #8341

    Pierre Laroche
    Participant
    • 6 Posts
    @pragmacafe
    This reply has been marked as private.
    #8351

    Jason
    Participant
    • 183 Posts
    @themoceratops

    Hi @pragmacafe,

    Thanks for the credentials.

    I took a look at your website and adapted the code snippet to make it work properly. Your options should all be displayed as expected now.

    I’m posting the updated snippet here for any other user that would encounter the same issue :

    .bps_form .editfield .bps-custom-select select option:empty {
        display: none;
    }

    Can you please confirm that it is working for you ?

    Best regards,

    #8352

    Pierre Laroche
    Participant
    • 6 Posts
    @pragmacafe

    Working perfectly! Thank you so much and have a great day!
    best regards

    #8354

    Jason
    Participant
    • 183 Posts
    @themoceratops

    You’re welcome 🙂

    Hope you have a great day as well!

    Best regards,

    #8407

    Pierre Laroche
    Participant
    • 6 Posts
    @pragmacafe

    Hello Jason,
    i have some questions, #1 as seen on image, is it possible to hide/remove the image profil from that menu, so that menu and sub items as well since i will use a custom menu?

    #2 on the image the text “Forgot your password?” is written from top to bottom, i’m wondering if i did something worg or if it was like that.
    Anyway to put it as normal? 😉

    #3 My last one is if it is possible, when a user subscribe, to have the option to change the visibility on the “Name” field.
    Instead of being visible to all, if it can be visible only for the user, otherwise, I would like to hide it.

    Thanks again for your help!
    Pierre
    pragmacafe.com

    In case, i’m giving you, in private, an admin login if you ever need it

    #8408

    Pierre Laroche
    Participant
    • 6 Posts
    @pragmacafe
    This reply has been marked as private.
    #8409

    Jason
    Participant
    • 183 Posts
    @themoceratops

    Hi @pragmacafe,

    In the future please try to create a new topic for each question you have. This allows us to be more organized and makes it easier for other members to find answers if they have the same questions as you. Doing that would be a great contribution to this forum 🙂

    1. By default there is no option to hide this element. However, since this can be resolved with a simple CSS snippet, I will exceptionally provide you with the code to hide this element:

    .main-navigation .navbar-nav--buddypress {
    	display: none;
    }

    Please note that we don’t usually provide code snippets (except for fixing bugs before an update) and we are only giving you this as a courtesy.
    You can paste this snippet by going in Appearance > Customize > Additional CSS from your admin dashboard.

    2. This is a known bug that happens only in Firefox browser. It will be fixed in the next update. Here is another code snippet that should fix the bug while you wait for the next update:

    #loginform .login-submit {
       float: none !important;
    }
    
    #buddypress .standard-form#signup_form textarea {
       width: 100% !important;
    }
    
    #buddypress:not(.youzer) div.dir-search .field_type_textarea label,
    #buddypress:not(.youzer) .standard-form .field_type_textarea label {
       margin-bottom: 0 !important;
    }

    3. The Name field is the only field for which you can’t change the visibility. This is a limitation from BuddyPress and unfortunately we can’t do anything about it. My suggestion would be to rename that field to something like “Username” or “Nickname” and then create your own “Name” field where you can choose your own visibility.

    Hope this helps.

    Best regards,

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.