I can not change the Grimlock Hero text anymore

Home Forums Gwangi – Dating & Matchmaking Community Theme Compatible Plugins Grimlock I can not change the Grimlock Hero text anymore

This topic contains 8 replies, has 2 voices, and was last updated by  Olivier Cardoen 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7118

    Gilles Deron
    Participant
    • 34 Posts
    @gillesderon

    Hello dear support team,

    This week-end my test site was hacked. This was caused by an old plugin: BP Follow which is not updated for a long time.
    I cleaned my site, uploaded a 1-day database backup, uninstall and delete BP Follow.
    I searched on the web and installed BP Followers Masters, which seems to be a beta but updated version of BP Follow.

    Front-side web, all seems OK.
    Back-side, in the administration section of the website, I cannot change the text of the Hero, as you can see on the uploaded picture.

    I re-uploaded the demo content and demo widgets, with no effect.

    Could you help me (again) with this new issue?
    If you need administrator access, the old one still works.

    Cheers,

    Gilles

    #7119

    Olivier Cardoen
    Participant
    • 382 Posts
    @themosaurusrex

    Hi @gillesderon,

    I’m not sure to know in which topic you shared these login info with us. Could you please post the user name and password in your next reply? You can mark it as private to keep this between us.

    Cheers,

    #7120

    Gilles Deron
    Participant
    • 34 Posts
    @gillesderon
    This reply has been marked as private.
    #7122

    Olivier Cardoen
    Participant
    • 382 Posts
    @themosaurusrex
    This reply has been marked as private.
    #7123

    Gilles Deron
    Participant
    • 34 Posts
    @gillesderon
    This reply has been marked as private.
    #7124

    Olivier Cardoen
    Participant
    • 382 Posts
    @themosaurusrex

    Hi @gillesderon,

    It’s very odd what happening to your Customizer… 🤷‍♂️

    The plugin causing this issue is Kirki Toolkit. Its assets are wrongly loaded from the wp-content/themes/plugins directory instead of the wp-content/plugins, causing the 404 error crashing the Customizer. However, this very plugin is used on EVERY Gwangi website along with Grimlock, as well as EVERY cusom website that we’ve made for our agency clients. And we’ve never faced such issue and we’re not facing it currently with our live demos.

    Also, please note that when activating the parent Gwangi theme on your website, everything is fine. And editing the values from the Customizer can be made safely.

    Our working theory is that someone might have made custom changes to your wp-config.php, like changing your WP_CONTENT_DIR constant for instance… Did you, by any chance, made some changes to this kind of settings, either via custom code, snippets or config?

    If that’s not the case and no further solution is found, you might consider switching back to the parent theme and start fresh, like you did with snippets. Gwangi Child is really useful when you add custom code by editing the functions.php file. Otherwise, we recommend using Gwangi.

    Best,

    #7125

    Gilles Deron
    Participant
    • 34 Posts
    @gillesderon

    Hi @themosaurusrex,

    Thanks a lot for your quick answer. Working directly with the parent theme is not a problem as the website is still in test.

    For you information, the wp-config.php file was not modified, I compared it with the config.php file from another test website for the same project (not hacked !!) and the only differences was normal (db adress, keys, etc…).

    I thank you a lot again for your fast solution.

    Have all a great week.

    Best,

    Gilles Deron

    #7126

    Gilles Deron
    Participant
    • 34 Posts
    @gillesderon

    Hello there, it is me again.

    Eureka, I found the bug (I am a little bit obstinate, sometimes :-D). For a wtf reason, the child theme was not at his right place on the server. Instead of …/themes/gwangi-child/the files, the directory tree was …/themes/gwangi-child/gwangi-child/the files… I don’t know what or who change the directory, but I moved the files back at the good place and activated the child theme instead of the parent one, and all is working, back and front-end.

    So tank you a lot again, but this time, I win…. XD

    Cheers,

    Gilles

    #7127

    Olivier Cardoen
    Participant
    • 382 Posts
    @themosaurusrex

    Hi @gillesderon,

    Great news! I’m glad that you’ve found a solution.
    It was indeed very odd… But at least, we’ve learn a new thing also about Kirki.

    Thank you for having investigated this further.

    Best,

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘I can not change the Grimlock Hero text anymore’ is closed to new replies.