Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

In regards to the COVID-19 situation

Your support team is currently doing their best to offer the best support possible despite the current COVID-19 situation. However during these exceptional circumstances, please note that you should expect a response time of 2-3 business days, until further notice.Rest assured that we will still do our best to handle your requests as soon as possible! Everyone stay safe and healthy! 😷

Navigation responsive issues

This topic is resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
    • 19 Topics
    • 55 Posts

    Hello!

    I have some issues with the menu and its responsiveness. There are some weird breakpoints where the menu is really awful. No issues on standard screensizes but a lot of complications when the user resizes the window for instance. The main issue is between 991px and 1234px.
    Before going through the css and redefining a million media queries, I was wondering if you had a quick fix or good suggestion to enhance this behavior.

    I’m attaching the screenshots of the different results I get at different breakpoints.

    Thanks!

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 2223 Posts

    Hi @pilgrimteam,

    Unfortunately, your navigation is too wide. I suggest you delete some items of the main navigation and put them in the pre-header, in a new menu.

    If this is not enough, you can also reduce your logo and play on the padding. This will help you.

    Best,

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 2223 Posts

    Hi @pilgrimteam

    Have you tried any of the advice above?

    If you want, we can make you a snippet to hide the username and keeping only the avatar, reduce the logo and change some padding. These changes will be applied only on tablet.

    What do you think ? I look forward to your return.

    Best,

    • 19 Topics
    • 55 Posts

    Hi @themodactyl! Unfortunately, none of these solutions fixed my issues.
    Firstly because I need all the pages in the menu, and also because (and that might be me just not looking hard enough) I don’t find how to add a secondary menu in the pre-header. That would be great if I could do that, though, because some things are less essential than others. I tried doing that through the customizer using the Grimlock navigation component but it’s not what I expected (it’s floating top – left, very big, covering my nav…)

    Regarding the snippet, i’d be glad to have it & I think it could also help other people. Thanks for offering 🙂

    Have a great weekend,

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    @pilgrimteam You can add an extra menu to your preheader using the Navigation Menu widget. It’s more suited to this region than the Grimlock Navigation Menu. The widget can contain any existing menu or one just created for this purpose. Once you’ve selected you menu, simply adjust the preheader layout to what’s best for your website. (Please see attached.)

    • 19 Topics
    • 55 Posts

    Hi, thanks again for all the effort put in the support!
    I have a weird format issue, which I realize is linked to the sticky nav.
    When sticky nav is activated, following @themosaurusrex ‘s advice doesn’t work (see screenshot 1)
    But it’s displaying as it should when “sticky nav” is unchecked (see screenshot 2) — though I need the sticky nav, duh ??‍♀️

    Probably fixable with some CSS but I notice the header design has a tendency to break when switching to other options (see screenshot 3 when I disable the secondary menu and just change my nav from top to left side??)

    Might be some configuration error/override on my side? I don’t detect it through the inspector.
    But there definitely seems to be an issue with the sticky nav ?

    At the moment it’s not urgent for me so I’m sticking (no pun intended) to the simple, 1 menu, breakable sticky nav, as long as we don’t add more elements to the menu it should be fine for now!

    But maybe it’s a case to crack for later…

    Cheers!

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1893 Posts

    @pilgrimteam OK, this is definitely an issue that needs to be fixed. I’ll leave this topic open for further investigation on our side.

    Anyway, I’m glad to read that you’ve been able to solve this by… Sticking… To the primary menu. ?

    You can rest assured that we’ve registered this issue and that we’ll try to fix this ASAP.

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 607 Posts

    Hi @pilgrimteam,

    We recently released a new version of your theme.
    Updating your theme, Grimlock plugins and all the other recommended plugins to the latest version should fix the pre-header issue.

    Dont’t hesitate to get back to us if you see some display issues with the navigation.

    Than you very much (again) for your valuable feedback!

    Cheers,

    • 19 Topics
    • 55 Posts

    Hey @themopteryx,
    You’re right, I hadn’t updated my theme…
    However I tried again now that everything is up to date and it still doesn’t display properly when the main nav is set to sticky (see screenshot).
    Any idea what’s causing this?

    Thanks a lot,

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 607 Posts

    Hi @pilgrimteam !

    Thank you for reaching out to us!

    It’s best if we take a quick look at this…

    Could you create a new website user for us please? If possible with administrator capabilities so we can make a quick check of your settings.
    You can post the user name and password in your next reply and mark it as private to keep this between us.

    Thank you.

    • 19 Topics
    • 55 Posts
    This reply has been marked as private.
    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 607 Posts

    Hi @pilgrimteam,

    Thank you for reaching out to us!

    The preheader area seems to be fine on your site (cf. screenshot). Maybe there was a cacheing issue?
    Can you confirm that the preheader displays correctly after clearing your browser’s cache?

    At the moment, I removed the widget from this area and I leave it up to you to add it again and adjust its display :).

    Please note that we are open to discussion about the display of this area!

    Cheers,

Roboraptor 🦖
Themosaurus Topic Closer

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Navigation responsive issues’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️