Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

Due to the decrease in our staff due to vacations, our response time may be longer.

Be sure we're doing our best to manage your topic as soon as possible.

Problem with links of menu

This topic is resolved
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • gil
    Participant
    • 32 Topics
    • 126 Posts
    @gill49

    Hi ! i have broken links :/

    In menu 1 circled in red, at “Community” I have 5 anomalies:/
    . the links “Members directory” (the bigger one), “members directory” and “all members” (the paths indicate /members) lead to an empty page (see screenshot 2)

    . The “groups directory” link (path /groups), same thing: empty page.
    “create a group” (/groups/create) sends to a 404 page.

    . The “social wall (blabla)” path (/activity) link returns to an empty content page.

    —->As a solution for these problems, I think I should re-download the original pages damaged by me and do new slugs.
    Can you tell me where they are in the unzipped file of the “mentor” theme, please, because I can’t find them?

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4913 Posts
    @themodactyl

    Hi Gil,

    Thank you for reaching out to us!

    I think some plugins might be missing. It’s best if we take a quick look at this. Could you create a new website user for us please? If possible with administrator capabilities so we can make a quick check of your settings. You can post the user name and password in your next reply and mark it as private to keep this between us.

    Also, are we free to deactivate plugins for our tests? In this case, I invite you to make a backup before we investigate your website further in order to make sure you don’t loose any data if something goes wrong.

    Thank you.

    gil
    Participant
    • 32 Topics
    • 126 Posts
    @gill49
    This reply has been marked as private.
    gil
    Participant
    • 32 Topics
    • 126 Posts
    @gill49

    Well, I have an additional concern to entrust to you: everything is upside down in the main menu of connected users.

    The problem came from the fact that I made settings simultaneously on desktop PC and on mobile phone. However, on a mobile phone, in the WP accounts –> menus section, the menus can change position with enormous ease!
    It was only after two involuntary manipulations of this kind that I realized my mistakes.
    Could you, Manathan, restore the initial situation, like that of the screenshot (and with your settings concerning my first request
    also)
    Thanks very much

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4913 Posts
    @themodactyl

    Hi Gil,

    I took a look and it seems you uncheck “Primary” in the menu settings in Dashboard > Appearance > Menus > Primary. I set it right. 🙂

    When translating your website, some custom links that were redirecting to a page are not right anymore as they still redirect to the english page. You need to replace them by your french pages. Please find the attached screenshot.

    Hope this will help you.

    You’re French? We say Hi from Belgium. 🇧🇪

    gil
    Participant
    • 32 Topics
    • 126 Posts
    @gill49

    Thanks for your help, Manhattan. Your help allowed me to get the menu as originally: be thankful.
    However, there is 1 link that returns to a bad page: it is the link “social wall (blabla)”, (in french in the text). I don’t know what page it originally links to.

    Second, which “others” page was it originally linking to?
    and what is the “only new york” page for?

    PS: in Belgium? But alors… you speak french? :))

    gil
    Participant
    • 32 Topics
    • 126 Posts
    @gill49

    Two more problems, Manathan:
    . in the menu “user logged in”, what should be the path of the item “create a group”? is it /members-directory/username, or just “/group-create” ?

    . In the “primary menu”, the “members” item links to a page with empty content. I can’t find this page in the WP dashboard.

    :/

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4913 Posts
    @themodactyl

    Hi Gil,

    Here is our feedback:

    1. Social Wall: Note that the right pages are set in Dashboard > BuddyPress > Pages. In your case, it seems the right page is “Activités du site”. that’s the page you need to add to your menu, not the “Activités” page. this page is empty and I suggest you to delete it as it’s a little confusing.
    2. Members: Same here. Your page “Membres” is empty because it is the page “Répertoire des Membres” that is set in BuddyPress settings.
    3. Only New York: This page should contain the “Swipe Directory” block that will allow you to display a swipe with your members. In Filter Profile Fields, you’ll be able to select some profile fields to display only specific users. For exemple: only women, only members between 20 and 30 years, …
    4. Create a group: To create a group, you have to go to the groups directory. In your case, the “Répertoire des groupes” page. Then, click on Create a group button. Then, you’ll be able to copy the url of this page and create a custom link in your menu with this url. Translation of a website can be a little tricky for the first time. Is it?

    Please note that these issues are related with the translation of a third party plugin, not with the use of your theme. When translating plugins, the pages their manage change as well and menus need to be updated. As theme authors, the installation, setting or debugging of third party plugins isn’t part of the support we usually provide. However, we tried our best to help you as much as we can. 🙂

    Hope this will help you.

    Best,

    En effet, nous parlons français. Toutefois, nous imposons l’anglais sur notre support car nous avons des utilisateurs dans divers pays. Nous espérons que notre réponse vous aidera à y voir plus clair! 🙂

    gil
    Participant
    • 32 Topics
    • 126 Posts
    @gill49

    Thanks Manathan, the problem is over !

    Manathan
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 4913 Posts
    @themodactyl

    You’re welcome Gil, I’m glad to read this topic is solved! 🙂

    If you’re happy with our theme, feel free to review our theme on our Themeforest page:
    https://themeforest.net/item/gwangi-dating-community-theme/21115855

    It’s very appreciated and it helps us making our products more known to new potential customers, which allow us more time to improve the quality over time and develop new features. It’s a win-win !

    And by doing this, you will be making a great contribution to our community! #SharingIsCaring ❤️

    Thank you!

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Problem with links of menu’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️

Discover MatchPress

Skip • Like • Super-Like

Add powerful matching features like Member likes, skips, super likes, conditional private messaging and much more.