problems with translations

This topic contains 26 replies, has 3 voices, and was last updated by  Themosaurus 1 month ago.

Viewing 25 posts - 1 through 25 (of 27 total)
  • Author
    Posts
  • #5204

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    – I have translated the entire theme into Spanish but the following words continue to appear in English

    #5224

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    These strings seem to be added to your page by plugins, not by the theme. So, you might need to translate your website a bit further to make it perfect. 🙂

    1) The “Submit” string should be included by the translations for BP Profile Search.

    2) “Continue Reading” is added by Grimlock and has not been translated to spanish yet. However, we’ve provided the POT file to translate. You can put your translations files like you might have done for other plugins, under:
    – wp-content/languages/plugins/grimlock-es_ES.po
    – wp-content/languages/plugins/grimlock-es_ES.mo

    Best,

    #5226

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    I did what you told me but it does not work yet the sentences are in English

    #5241

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    We will investigate further to find from where this issue is coming from. We will be back to you ASAP.

    Thank you for your patience.

    Regards,

    #5265

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    thanks

    #5287

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus
    This reply has been marked as private.
    #5420

    DEMENTE
    Participant
    • 122 Posts
    @chilepower
    This reply has been marked as private.
    #5421

    DEMENTE
    Participant
    • 122 Posts
    @chilepower
    This reply has been marked as private.
    #5431

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    Thank you for sending us your translation file. We will investigate it further to find from where this issue is coming from.

    We will be back to you ASAP.

    Thank you for your patience.

    Regards,

    PS: Please note that we’ve marked your previous reply as private as you were sharing personal information. 😉

    #5525

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    Could you try to rename your file gwangi-es_CL.po?
    You seem to have set your language to Spanish from Chile instead of Spanish from Spain and that might solve your issue. Currently, WP might not be able to load the correct translation files.

    Best,

    #5703

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    I have followed his instructions, but the phrase “SUBMIT” is still in English http://prntscr.com/mvpwtc

    #5715

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    Could you make sure to rename your file gwangi-es_CL.po please? On the shared screenshot, your file is still named gwangi-es_ES.po.
    You seem to have set your language to Spanish from Chile instead of Spanish from Spain and that might solve your issue. Currently, WP might not be able to load the correct translation files.

    Best,

    #5718

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    I already did that but still the problem is still

    #5722

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    Could send us the translation file via email please?

    Thank you.

    #5723

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    sent

    #5731

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus
    This reply has been marked as private.
    #5749

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    You have to rename your file gwangi-es_CL.po. On the shared screenshot and for the file sent via email, it is still named gwangi-es_ES.po!

    If you have set your language to Spanish from Chile instead of Spanish from Spain, you must have the correct file names. Currently, WP is not be able to load the correct translation files as you have provided the files for Spanish from Spain.

    Please try with the following files:
    https://files.themosaurus.com/languages/gwangi-es_CL.po
    https://files.themosaurus.com/languages/gwangi-es_CL.mo

    This will solve your issue (please review screenshot).

    Best,

    #5753

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    my translation files are in Spanish from Spain and in my wordpress language too, I do not understand what is going on

    #5754

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    It seems that I have explained myself wrongly, my wordpress is configured in the Spanish language of Spain, not in the Spanish of Chile and my translation files are in Spanish of Spain too

    #5759

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    I have everything right I can not understand why the phrases are not translated and they are only 3 sentences

    #5767

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    Thank you for clarifying your request.

    When placing your files them under wp-content/languages/themes and selecting “Español” as website language, everything is working fine for us (see attached screenshot).

    Our current testing files are:
    wp-content/languages/themes/gwangi-es_ES.po
    wp-content/languages/themes/gwangi-es_ES.mo

    We’re sorry to say that we have really no clue of what might cause your issue on your side. Could make sure that you’ve placed every file in the right spot and that you gave it the right name please?

    Best,

    #5771

    DEMENTE
    Participant
    • 122 Posts
    @chilepower

    Apparently we have a small but very important problem, then, because I have reviewed my files many times and everything is fine, that is why I come to you, if you wish, you can enter via FTP to my website to make a complete review and verify that everything is perfect

    #5787

    Themosaurus
    Keymaster
    • 1669 Posts
    @themosaurus

    Hi @chilepower,

    Could you please create a new website user for us? If possible with administrator capabilities so we can make a quick check of your settings.
    Could you also send us your FTP credentials?

    You can insert them in your next reply and mark it as private to keep this between us.

    Regards,

    #5798

    DEMENTE
    Participant
    • 122 Posts
    @chilepower
    This reply has been marked as private.
    #5806

    Jason
    Participant
    • 127 Posts
    @themoceratops

    Hi @chilepower,

    Thanks for the info.

    After taking a look, we have finally fixed the issue with the Gwangi language file. To be honest I am not sure what was the problem. I tried different things with the file location and file name, I downloaded the language file from your server, edited a couple of properties via the Po-Edit software and re-saved it. After that, the text was finally translated on your site.

    In your homepage form the “from” and “to” are still not translated though, but that is because these texts are from the BP Search Profile plugin, not from Gwangi.

    Best regards,

Viewing 25 posts - 1 through 25 (of 27 total)

The topic ‘problems with translations’ is closed to new replies.