Userprofile

This topic contains 13 replies, has 2 voices, and was last updated by  Olivier Cardoen 1 month, 4 weeks ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #6529

    Werner
    Participant
    • 25 Posts
    @creation

    The searchform (by age from to) does not work.
    And I noticed that some user-fields are missing if I use different browsers.

    In Firefox they are shown, but on Chrome not (see screenshot)

    #6531

    Olivier Cardoen
    Participant
    • 239 Posts
    @themosaurusrex

    Hi @creation,

    The fields displayed on our demo are only available if you use our generated fields. You can choose which ones to display when visiting the Customizer.

    As described in our setup guide (https://doc.themosaurus.com/finishing-buddypress-setup/), you can generate the default fields by a single click. Only these are the ones that are displayed on member lists and member profile.

    If these are not showing on your member directory, the values might be simply have been left empty. However, if these fields are not showing in the admin, it seems that you might have skipped some steps from the setup guide. It’s best to complete every step before going to next otherwise some imports will be broken, like your homepage and directory search forms, for instance.

    To solve this, you need to go first to your BuddyPress settings and finish its setup:

    Finishing BuddyPress Setup


    This step will help you to generate all the missing profile fields.

    Your next step will be re-save your homepage and directory search forms.
    We use BP Profile Search (https://wordpress.org/plugins/bp-profile-search/) to showcase the profile search feature on our demos.
    You can edit the homepage search form by visiting “Users > Profile Search” in your dashboard, where you will find every existing profile search forms.
    Just edit your forms and click “Save” without changing anything.

    Finally, you can test by adding some values to these fields for your test members. So make sure that for every search values, some of your test members have been the required values.

    It should solve your first issue.

    To learn more about BP Profile Search forms, please read also the following posts:

    Add new fields to homepage search form

    My profile search form seems to be broken

    Regarding the issue with the browser, please make sure you logged in both website. If some test values are supposed to be private, they won’t be displayed in your browser if you’re not logged in.

    As this issue is related with the BP Profile Search, you can also try to reach the plugin authors. They will be more informed and better suited to help you.

    To go further, we invite you to post your request on their support forums:
    https://wordpress.org/support/plugin/bp-profile-search/

    We remain available for all support requests related with the use of your theme.

    Best,

    #6533

    Werner
    Participant
    • 25 Posts
    @creation

    Thanks.
    No I resolved evertyhing.
    Only the search by age range is not working correctly.
    Every filter works, but not the age range.
    What can I do?

    #6542

    Olivier Cardoen
    Participant
    • 239 Posts
    @themosaurusrex

    Hi @creation,

    Could you please create a new website user for us? If possible with administrator capabilities so we can make a quick check of your settings.
    You can post the user name and password in your next reply and mark it as private to keep this between us.

    Cheers,

    #6556

    Werner
    Participant
    • 25 Posts
    @creation
    This reply has been marked as private.
    #6569

    Werner
    Participant
    • 25 Posts
    @creation
    This reply has been marked as private.
    #6572

    Olivier Cardoen
    Participant
    • 239 Posts
    @themosaurusrex
    This reply has been marked as private.
    #6573

    Olivier Cardoen
    Participant
    • 239 Posts
    @themosaurusrex

    Hi @creation,

    You’re right, your age range field seems broken and it’s not taken into account by BP Profile Search, like it does for other fields. Unfortunately, I gave a look to your settings and at first glance, everything seem to be set correctly…

    However, you seem to be running late with plugin updates, including with our theme and BP Profile Search. So, I recommend that you try to update Gwangi and all the required plugins to the latest version, as it might fix this issue.

    To update your theme, you can download and install the Envato Market plugin (https://envato.com/market-plugin/) on your WordPress site. Once the plugin is installed and activated, go to “Envato Market” in your admin menu and follow the instructions under “Activate Envato API Connection”. When this is done, you will see your purchased themes under the “Themes” tab and you should be able to update your Gwangi theme from there by clicking the “Update available” button.

    If the issue persist after updating your install, it’s best if you try to reach the authors of BP Profile Search. They will be more informed and better suited to help you.

    To go further, we invite you to post your request on their support forums:
    https://wordpress.org/support/plugin/bp-profile-search/

    We remain available for all support requests related with the use of your theme.

    Best,

    #6574

    Werner
    Participant
    • 25 Posts
    @creation
    This reply has been marked as private.
    #6585

    Olivier Cardoen
    Participant
    • 239 Posts
    @themosaurusrex

    Hi @creation,

    We’re sorry for the trouble that you’re experiencing.

    Unfortunately, we have no clue. 🤷‍♂️

    As this issue is related with the BP Profile Search, it’s best if you try to reach the plugin authors. They will be more informed and better suited to help you.

    To go further, we invite you to post your request on their support forums:
    https://wordpress.org/support/plugin/bp-profile-search/

    We remain available for all support requests related with the use of your theme.

    Best,

    #6592

    Werner
    Participant
    • 25 Posts
    @creation
    This reply has been marked as private.
    #6597

    Werner
    Participant
    • 25 Posts
    @creation
    This reply has been marked as private.
    #6602

    Werner
    Participant
    • 25 Posts
    @creation

    Fixed it now!
    They updated the plugin and now it works!
    Thanks!!

    #6605

    Olivier Cardoen
    Participant
    • 239 Posts
    @themosaurusrex

    Hi @creation,

    I’m glad to read that you’ve solved your issue.

    Best,

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Userprofile’ is closed to new replies.