WooCommerce Plugin disabling certain functions in Gwangi theme.

Home Forums Gwangi – Dating & Matchmaking Community Theme Compatible Plugins WooCommerce WooCommerce Plugin disabling certain functions in Gwangi theme.

This topic contains 9 replies, has 2 voices, and was last updated by  Themosaurus 2 months, 4 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5361

    Lanre Oluwafemi
    Participant
    • 15 Posts
    @kobolafem

    Hello. I have noticed that the Woocommerce plugin keeps messing with my theme configurations after I activate it. E.g, after activation of Woocommerce, I’m unable to customize the theme anymore as when I click on the ‘customize’ link on the Admin tab the website crashes with a ‘page isn’t working’ error message (as attached in the screenshot below). I don’t understand why this happens because the moment I deactivate Woocommerce everything goes back to normal. Also, the topmost tab of the user profile (that normally appears in black) would disappear upon activation. I have attached two screenshots to better explain the situation that happens before and after Woocommerce plugin activation. Thanks in anticipation of your assistance.

    #5368

    Themosaurus
    Keymaster
    • 1670 Posts
    @themosaurus

    Hi @kobolafem,

    Thank you for bringing this to our attention. We will investigate further to find from where this issue is coming from.

    We will be back to you ASAP.

    Thank you for your patience.

    Regards,

    #5386

    Themosaurus
    Keymaster
    • 1670 Posts
    @themosaurus

    Hi @kobolafem,

    Unfortunately, we’re not experiencing the issue that you’re facing and we’re not able to reproduce it.

    First, could make sure that your website is running the latest version of our theme (1.1.9) and that you have also Grimlock for WooCommerce activated on your website? The issue might simply be the missing add-on plugin to bridge features from WooCommerce and Grimlock.

    Could you please create a new website user for us? If possible with administrator capabilities so we can make a quick check of your settings.
    You can post the user name and password in your next reply and mark it as private to keep this between us.

    Cheers,

    #5387

    Lanre Oluwafemi
    Participant
    • 15 Posts
    @kobolafem
    This reply has been marked as private.
    #5388

    Lanre Oluwafemi
    Participant
    • 15 Posts
    @kobolafem
    This reply has been marked as private.
    #5408

    Themosaurus
    Keymaster
    • 1670 Posts
    @themosaurus

    Hi @kobolafem,

    Thank you for share access to your website with us. It seems that WooCommerce isn’t installed yet. Did you remove it? And do you agree that we install and activate it to run our tests and look for the issue?

    Currently, you only have Grimlock for WooCommerce activated. To enjoy all ecommerce features, you have to install both.

    Thank you.

    #5409

    Lanre Oluwafemi
    Participant
    • 15 Posts
    @kobolafem

    Thanks for your mail. Yes. Please feel free to test the WooCommerce plugin. And thanks in anticipation of your disabling the particular field I mentioned in the buddypress private messaging ( hope it won’t affect the public messaging coz I only need that field disabled for private messaging only). Do let me know when you are done testing. Thanks again and all the best.

    #5440

    Themosaurus
    Keymaster
    • 1670 Posts
    @themosaurus

    Hi @kobolafem,

    We’re really sorry. It seems that installing WooCommerce crashed your website. Could share your FTP access with us, so we can manually remove the plugin please? You can also keep these info private and remove it by yourself.

    However, we do need to know what crashing your WooCommerce as it seems very odd… 🤔

    To help us getting clues and find a solution to this issue, please activate logging on your website, just turn WP_DEBUG to true, by pasting the following code lines in your wp-config.php file, just before the line that says ‘That’s all, stop editing! Happy blogging.’:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings 
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    More on this in the following topic: https://codex.wordpress.org/Debugging_in_WordPress

    Thank you.

    #5443

    Lanre Oluwafemi
    Participant
    • 15 Posts
    @kobolafem

    I have removed the plugin so the site is back up and running. I guess I just won’t use woocommerce for now till I can figure out what to do about the problem. I am still expecting an update on the buddy press private messaging field. Thanks.

    #5444

    Themosaurus
    Keymaster
    • 1670 Posts
    @themosaurus

    OK great! Did you add the previous snippet to you wp-config.php? Maybe this will help us to find from where this issue stems from.
    If we can solve it, we’ll try to give it a go. Otherwise, we could still contact the responsible plugin author to ask him to solve your conflict.

    Anyway, to do so, we have to review to error logs that will be generated when we’ll try to activate WooCommerce again. (Please note that doing so, you will probably need to remove the plugin once again.)

    Cheers,

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘WooCommerce Plugin disabling certain functions in Gwangi theme.’ is closed to new replies.