wp-login and WPML

This topic contains 7 replies, has 3 voices, and was last updated by  Olivier 3 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23907

    Gilles Deron
    Participant
    • 70 Posts
    @gillesderon

    Hello dear Themosaurus Support Members.

    I use WPML to manage my website in French and English.
    But the /wp-login page is showing only in French (which is the basis language of the website).

    The WPML Support says to put the WPML option to Language name added as a parameter.
    But I saw on Gwangi documentation that the best is to use different directory: /fr/, /en/.

    I search your documetnation and forum for help, but I didn’t find anything…

    Could you helpo me?

    Regards,

    Gilles

    #23955

    Manathan
    Keymaster
    • 1463 Posts
    @themodactyl
    Themosaurus Support

    Hi @gillesderon,

    Thank you to bring this issue to our attention.

    To translate this page, you should search the sentences in Dashboard > WPML > String translation.

    Here is an article from the WPML documentation. I really think it will help you solve this.

    WPML String Translation

    I’m waiting for your feedback. 🙂

    Best,

    #23976

    Gilles Deron
    Participant
    • 70 Posts
    @gillesderon

    Hello @themodactyl,

    Thanks for your answer.
    However, this is not helpfull.
    I must have expressed myself incorrectly.

    The strings are well translated using WPML.
    When I go to the homepage and switch the language to English, the page reload well in English.
    But when I hit the button to login, the next page (/wp-login) is in French.
    The login button is in the hero zone, the text around is well translated using WPML but the link (/wp-login) is the same in French and English.
    And this link leads to the french wp-login….

    #23977

    Gilles Deron
    Participant
    • 70 Posts
    @gillesderon
    This reply has been marked as private.
    #23981

    Gilles Deron
    Participant
    • 70 Posts
    @gillesderon
    This reply has been marked as private.
    #23986

    Manathan
    Keymaster
    • 1463 Posts
    @themodactyl
    Themosaurus Support

    Thank you for your feedback. 🙂

    Maybe these topics will help you to solve your issue as they seem to answer the same concern:

    Please note that this issue is related with the customization of a third party plugin, not with the use of your theme. As theme authors, the installation, setting or debugging of third party plugins isn’t part of the support we will provide.

    We remain available for all support requests related with the use of your theme.

    Regards,

    #23999

    Gilles Deron
    Participant
    • 70 Posts
    @gillesderon

    Thank you for your search, but I knew the links you proposed.

    Can you assure that I can set WPML with option to Language name added as a parameter with your theme and Woocommerce?
    I made a try, but it was not satisfactory.

    I’m surprised you say the issue is related with customization of a third party plugin, as I notice the problem and his css class is grimlock-section__footer.

    So I think it is a piece of Gwangi which is not properly prepared for WPML.

    #24052

    Olivier
    Moderator
    • 1843 Posts
    @themosaurusrex
    Themosaurus Support

    Hi @gillesderon,

    I noticed that you have Clean Login installed (https://wordpress.org/plugins/clean-login/), it is probably messing with either WPML or Grimlock Login. I also noted that your Register and Log In page has been translated correctly. (Please see attached.)

    Please note that Grimlock Login is only applying styles to the default login page, and it is not interfering with WP core functions, which should allow plugins WPML to do their jobs correctly. In consequence, this would be very odd to discover that Gwangi or Grimlock Login are the root cause of this issue.

    My best guess remains that your issue might probably caused by some conflicting third party plugin or some extra code snippet as we are not facing this issue on our side.

    Could you deactivate all plugins that have not been installed with your theme during its setup and all existing custom PHP code snippets please? And then, could you confirm me that the issue is still persisting please?

    Please also make sure that you have the latest theme version and that all recommended plugins are up-to-date. Finally, you could also consider clearing all activated caching system as well as your browser cache before investigating any further.

    Thank you! 🙂

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘wp-login and WPML’ is closed to new replies.