Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

In regards to the COVID-19 situation

Your support team is currently doing their best to offer the best support possible despite the current COVID-19 situation. However during these exceptional circumstances, please note that you should expect a response time of 2-3 business days, until further notice.Rest assured that we will still do our best to handle your requests as soon as possible! Everyone stay safe and healthy! 😷

Login Loop

This topic is resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Aaron Mireles
    Participant
    • 7 Topics
    • 14 Posts
    @acm1985

    Hello,

    I am having an issue to where people who complete the registration process (Input all information, get email verification link, click it and are directed to login again) are unable to login. It’s almost as if they are stuck in a login loop. See screenshot of beta tester sharing their feedback.

    This is also something i encounter when i try to login in incognito mode. I do have a 2FA plugin enabled, but even after disabling that plugin i still run into the same issue. I know this is a step before they become a PMP member, but i am posting in this thread to ensure i get some help in regards to what is happening. I have created a separate environment and plan on enabling plugins one by one to see if i can fix the issue.

    Here’s a list of plugins i have installed. All are up to date, including my theme.

    Akismet Anti-Spam
    Atomic Blocks – Gutenberg Blocks Collection
    bbP topic count
    bbPress
    BP Better Messages
    BP Birthday Greetings
    BP Profile Search
    Select BuddyPress
    BuddyPress
    Select BuddyPress Docs
    BuddyPress Docs
    BuddyPress Global Search
    BuddyPress Notifications Widget
    CoBlocks
    Code Snippets
    Duplicate Page
    Easy Custom Sidebars
    Elementor
    Envato Market
    Grimlock
    Grimlock Animate
    Grimlock for Author Avatars List
    Grimlock for bbPress
    Grimlock for BuddyPress
    Grimlock for Elementor
    Grimlock for Jetpack
    Grimlock for Knowledge Base for Documents and FAQs
    Grimlock for The Events Calendar
    Grimlock for Yoast SEO
    Grimlock Isotope
    Grimlock Login
    Jetpack by WordPress.com
    Kirki Customizer Framework
    Deactivate
    The Ultimate WordPress Customizer Framework
    Knowledge Base for Documents and FAQs
    Menu Image
    Microthemer
    My Private Site
    Paid Memberships Pro
    Paid Memberships Pro – Add Name to Checkout Add On
    Paid Memberships Pro – Address For Free Levels Add On
    Paid Memberships Pro – Advanced Levels Page Shortcode Add On
    Paid Memberships Pro – BuddyPress Add On
    Paid Memberships Pro – Extra Expiration Warning Emails Add On
    Paid Memberships Pro – Mailchimp Add On
    Paid Memberships Pro – Register Helper Add On
    Paid Memberships Pro – Shipping Add On
    Paid Memberships Pro – Zapier Add On
    PMPro Customizations
    PMPro Social Locker
    Deactivate
    rtMedia for WordPress, BuddyPress and bbPress
    Social Articles
    The Events Calendar
    Two Factor
    WordPress Popular Posts
    WP Meta and Date Remover
    Yoast SEO
    Zapier for WordPress

    Erembert
    Participant
    • 6 Topics
    • 34 Posts
    @beuza

    Hi,
    Facing the same problem.
    Regards,

    Aaron Mireles
    Participant
    • 7 Topics
    • 14 Posts
    @acm1985

    Hello Cera Builders,

    This is obviously a problem with your theme if you are having two people experiencing this issue. I am currently in beta testing when my users found this error, which is preventing a lot of my users from even getting past the login screen and completing my beta testing tasks. Needless to say this is a HUGE problem that needs to be addressed asap.

    Please help us fix this issue.

    Best,

    AM

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 610 Posts
    @themopteryx

    Hi @acm1985,

    We are waiting for your admin credentials since we asked for them in another ticket (https://support.themosaurus.com/forums/topic/widget-area-covering-my-cpage-content/#post-13729).
    We will look at both issues at the same time.

    Note that as our theme doesn’t manage login and register features, this problem is probably due to an incompatibility between 2 plugins, a bug coming from a single plugin or redirections settings.

    But it’s better if we take a look at it.

    Thank you in advance.

    Regards,

    Erembert
    Participant
    • 6 Topics
    • 34 Posts
    @beuza

    Hi @acm1985,

    I have fixed it. My advice is to check at your profile field manager if all your required fields are visible during the registration.
    If it doesn’t fix your problem, i have found it on the web:
    “one customer deleted the BuddyPress plugin and reinstalled and they told us that fixed the issue; two customers deleted their “register” pages and created new ones, and they told us that fixed the issue for them”

    Regards,
    Laurent

    Aaron Mireles
    Participant
    • 7 Topics
    • 14 Posts
    @acm1985

    Hello @themopteryx,

    I have sent over my admin credentials for you to review both issues. I hope you can make swift work of addressing these issues as users are unable to login successfully at this point and it is drastically disrupting my beta testing.

    Best,

    AM

    Aaron Mireles
    Participant
    • 7 Topics
    • 14 Posts
    @acm1985

    I wanted to update this thread with a few things I found. After careful review, I noticed that sometimes i am in fact getting a login loop. However, sometimes I also see that it only appears to be a login loop. When i login and get directed back to ym registration page again, I can actually click on my side navigation and experience the pages as a registered user. Again, both situations are extremely troubling, but i just wanted to give you more insight into what i found so you can try it yourself on your end.

    Thanks,

    AM

    Aaron Mireles
    Participant
    • 7 Topics
    • 14 Posts
    @acm1985

    One final thing i want your team to review is i am also unable to reset my password. After trying to reset it, it just drops me back into my registration page, like when you get the login loop.

    AM

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 610 Posts
    @themopteryx

    Hi @acm1985,

    Thank you for bringing this to our attention. We will investigate further to find from where this issue is coming from.

    We will be back to you ASAP.

    Thank you for your patience.

    Regards,

    Aaron Mireles
    Participant
    • 7 Topics
    • 14 Posts
    @acm1985

    Hello @themopteryx,

    Thank you. I appreciate your team working on this and would greatly appreciate a response within the day so i can get back to business regarding my site.

    Thanks,

    AM

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 2063 Posts
    @themosaurusrex

    Hi @acm1985,

    Your support team is currently doing their best to offer the best support possible despite the current COVID-19 situation.

    However during these exceptional circumstances, please note that you should expect a response time of 2-3 business days, until further notice.

    Rest assured that we will still do our best to handle your requests as soon as possible!

    Thank you for understanding.

    Stay safe and healthy! ?

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 610 Posts
    @themopteryx

    Hi @acm1985,

    I think I figured out where the problem’s coming from. This “loop” was probably caused by a misconfiguration of the Paid Memberships Pro plugin.

    Actually, in the settings of this plugin the login page was configured to redirect all login urls to the “register” page (BuddyPress default register page). We think that it’s better to leave the default login page of WordPress (or to use a dedicated page only for login feature).

    Due to this misconfiguration, all redirections to the login page were actually redirected to the register page.
    I took the liberty of choose the default WordPress login as your login page.

    I hope that helped!

    Cheers,

Roboraptor 🦖
Themosaurus Topic Closer

Hi there,

This topic has been inactive for a while now so we will be closing it to keep the forum tidy. Don't hesitate to create a new topic if you still need help and we'll be glad to help you!

Best regards,
The Themosaurus team.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Login Loop’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️

Discover MatchPress

Skip • Like • Super-Like

Add powerful matching features like Member likes, skips, super likes, conditional private messaging and much more.