Support only during business hours : Monday to friday, from 8:30 am – 5:30 pm CEST

In regards to the COVID-19 situation

Your support team is currently doing their best to offer the best support possible despite the current COVID-19 situation. However during these exceptional circumstances, please note that you should expect a response time of 2-3 business days, until further notice.Rest assured that we will still do our best to handle your requests as soon as possible! Everyone stay safe and healthy! 😷

Google font doesnt work

This topic is resolved
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • Gordon
    Participant
    • 3 Topics
    • 9 Posts
    @gordon

    Hi guys. First of all thank you so much for this awesome theme. I have not set it up completely – but it already looks amazing.

    Via the customizer I choosed the Google font for text: Titilium Web, that is working fine.

    But for headings I choosed the Google font Quicksand. And this font is not working. BUT: When I am in the Theme Customizer, the Quicksand font is shown.

    Do you have any hint for me how to fix it?

    Best regards
    Gordon

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1895 Posts
    @themosaurusrex

    Hi @gordon,

    Thank you so much for the kind words. We really appreciate! ?

    Could you create a new website user for us please? If possible with administrator capabilities so we can make a quick check of your settings.
    You can post the user name and password in your next reply and mark it as private to keep this between us.

    Cheers,

    Gordon
    Participant
    • 3 Topics
    • 9 Posts
    @gordon
    This reply has been marked as private.
    Gordon
    Participant
    • 3 Topics
    • 9 Posts
    @gordon
    This reply has been marked as private.
    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1895 Posts
    @themosaurusrex

    Hi @gordon,

    We will investigate further to find from where this issue is coming from.

    We will be back to you ASAP.

    Thank you for your patience.

    Regards,

    Olivier
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 1895 Posts
    @themosaurusrex

    Hi @gordon,

    Kirki is the plugin managing fonts for our theme. Usually, it dynamically loads them in Customizer for better previewing the changes and then, it downloads the desired font files to your server to improve page loading times.

    Issue related with loading server static files are frequently related with permission settings. Some fine tuning or changing the permission settings to let the font file correctly load using your FTP client will probably fix your issue.

    For more, please also read the following topics addressing the same issue:
    https://support.themosaurus.com/forums/topic/my-website-super-slow/
    https://support.themosaurus.com/forums/topic/icons-dont-load-and-login-page/

    Best regards,

    Gordon
    Participant
    • 3 Topics
    • 9 Posts
    @gordon

    Hi Olivier.

    Unfortunately the font is still not working. I read the two threads that you have sent me and changed the permissions of the folder. But it doesnt work.

    I also saw that this issue only is existent at Chrome and Firefox. In Safari the font is displayed correctly.

    Do you have any other solution?

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 609 Posts
    @themopteryx

    Hi @gordon,

    Here is your full error notice :
    Access to font at 'http://wordpress.***.de/wp-content/uploads/2020/01/6xK-dSZaM9iE8KbpRA_LJ3z8mH9BOJvgkP8o18I.woff' from origin 'http://***.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

    The main problem is that the font is blocked by the browser (apparently not in Safari) since it’s loaded from an external url (“wordpress.***.de/…”) and not from your actual domain name.

    After some research, this issue seems to be related to the cache of this plugin (Kirki plugin).
    And apparently it works if you change your font (other than quicksand), which seems to indicate that only this one is cached.

    Can you try to delete all fonts files via your ftp (/wp-content/uploads/2020/01/, all .wof files like “dSZaM9iE8KbpRA_LJ3z8mH9BOJvgkP8o18I.wof”) and then flush the cache of this plugin by entering this url (YOURSILEURL.COM/?action=kirki-reset-cache) and your browser cache too.

    You can find more informations on this thread (https://wordpress.org/support/topic/kirki-loading-google-fonts-from-old-domain-after-migration/page/2/) and maybe reach the plugin author if the above fix doesn’t worked for you.

    Regards,

    Gordon
    Participant
    • 3 Topics
    • 9 Posts
    @gordon

    Hi Jean-Pascal. Awesome! That worked perfectly and the font is shown again.

    Thank you so much for your great support.

    Best regards
    Gordon

    Jean-Pascal
    Keymaster
    Themosaurus Support
    • 0 Topics
    • 609 Posts
    @themopteryx

    Hi @gordon,

    Glad this trick worked for you!
    And thanks to you for your valuable feedback, this case will also be useful to other users who may have the same issue.

    Best regards,

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Google font doesnt work’ is closed to new replies.

Troubleshooting Demo Imports

You're trying to setup your theme but you're experiencing errors when importing the demo content? Or you've just followed the setup guide but your website doesn't look exactly like our demo? These are common issues for which you can find easy and quick fixes.

Happy With our Support So Far?

Feel free to review our theme on Themeforest! It helps us making our products more known to new potential customers, which allow us more time to improve the quality and develop new features. #SharingIsCaring ❤️